您现在的位置:首页 > 帮助中心 > 服务器问题 > Windows 2003 IIS 里面无法选择asp.net 3.5 的解决办法

Windows 2003 IIS 里面无法选择asp.net 3.5 的解决办法

来源:中国U网 日期:2011-07-18 类别:服务器问题 喜欢:0
ASP.NET 3.5 安装之后无法在IIS里面选择,其实.NET 3.5的整个核心的架构还是建立在 .NET 2.0 之上,所以选择.NET 2.0即可。

在Windows 2003上安装好ASP.net 3.5 sp1之后,却发现在IIS 6.0里面无法找到.net 3.5的选项(如下图),重新安装也是一样的问题,那可如何是好呢?

IIS .net 3.5

其实ASP.NET 3.5 只是使用 .Net Framework 3.5 的组件(assembly)而已!整个核心的架构还是建立在 .NET 2.0 之上,.NET Framework 的 API 都没变,只是到了 .NET 3.5 很多 assembly 都重新写过了,且执行的速度也比 .NET 2.0 的组件还快。

实际上 .NET Framework 3.5 是运行环境,.NET 2.0是iis扩展的版本号,目前即使安装了.NET Framework 3.5,iis扩展的版本号依然是2.0。但是如果是VS 2008下做的程序,明确指明了.NET Framework 3.5 ,就必须需要 .NET Framework 3.5 的支持,.NET Framework 3.5 的内核还是2.0,所以你只要选择2.0就可以了。

版权所有 中国U网 侵权必究 免责声明 互联网不良信息举报
旺旺:点击这里给我发消息
售前:cuwww
售前:cuwww
售后:cuwww
技术:cuwww